3DS - Mastercard Issues
Incident Report for Trust Payments
Resolved
Status – Resolved

Please be advised that the issue impacting 3DS transaction processing with Mastercard has now been resolved. We apologise for any inconvenience caused.

If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 30, 2022 - 13:51 UTC
Monitoring
Status – Update on issue

Please be advised that customers may continue to experience intermittent 3DS transaction failures via Mastercard.
Mastercard is reporting that all major markets outside of India should now see a majority of transaction impact come to an end. We are seeing an improvement in successful authentication volumes and will continue to monitor the situation closely.

Mastercard has informed us that all of their requisite teams remain engaged with the issue and are working towards full restoration of services.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 30, 2022 - 11:16 UTC
Update
Status – Investigating the issue

Please be advised that customers may experience intermittent 3DS transaction failures currently via Mastercard. We are treating the universal issue as a matter of urgency. We will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 30, 2022 - 11:08 UTC
Investigating
Status – Investigating the issue

Please be advised that customers may experience intermittent 3DS transaction failures currently via Mastercard. Mastercard have confirmed that they have turned off all 3D Secure processing for Mastercard transactions. Mastercard are working to correct the issue as soon as possible.
We will be providing regular updates to this issue as we receive them and are continuing to track impacts to our customers.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 30, 2022 - 09:13 UTC
This incident affected: TRU Security (3DS) (3DS API (Server-to-Server), EMV 3DS).