POS Transactions - Settlement Payments Delayed
Incident Report for Trust Payments
Resolved
Dear Customer

Please be advised we have completed all remediation activity to resolve the double-billed POS transactions that occurred on Monday 14 November. We have identified our impacted customers and will provide a further update through direct e-mail contact.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 19, 2022 - 10:58 UTC
Update
Dear Customer,

Status – Update on issue

We are continuing to urgently investigate the double-billed POS transactions captured on Monday 14 November and apologise for the inconvenience this may be causing.

Please be assured that we are doing everything we can to resolve this issue, we have identified our impacted customers and will continue to provide regular updates as they emerge through direct e-mail contact.

Your patience and understanding are fully appreciated as this issue is resolved.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 17, 2022 - 18:31 UTC
Identified
Dear Customer

Please be advised any outstanding POS transactions captured on 14th November have now been successfully processed, however we are aware some cardholders have been debited twice for their purchases on 14th November.

We are treating the issue as a matter of urgency to identify all transactions that have been debited twice in order to begin the process to refund them today and ensure funds are returned to your cardholders from tomorrow morning.

We will provide further updates in due course. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 17, 2022 - 13:45 UTC
Monitoring
Dear Customer

Please be advised the outstanding POS transactions captured 14th November have now been successfully submitted. Settlement for these transactions is expected to be made to merchant bank accounts from tomorrow morning.

We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 16, 2022 - 16:13 UTC
Update
Dear Customer,

Please be advised the expected resolution to settle transactions captured on 14th November has been unsuccessful. Customers will experience delayed bank settlement payments for these transactions by at least 48 hours for transactions captured on 14th November.

However, American Express transactions captured on 14th November have now been successfully settled.

We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 16, 2022 - 12:01 UTC
Investigating
Dear Customer,

Please be advised the expected resolution to settle transactions captured 14th November has been unsuccessful. Customers will experience delayed bank settlement payments for these transactions by at least 48 hours for transactions captured on 14th November.

However, American Express transactions captured 14th November have now been successfully settled.

We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 16, 2022 - 09:52 UTC
Monitoring
Dear Customer,

Status – Update on settlement payments delay

We continue to treat the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 15, 2022 - 16:34 UTC
Update
Dear Customer,

Please be advised transactions captured 14th November have been successfully submitted for settlement to Trust Payments, have been accepted and will be processed through clearing overnight and in to tomorrow. However, customers will experience delayed bank settlement payments for these transactions by at least 24 hours.

American Express transactions captured 14th November remain unsettled at this time.

We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 15, 2022 - 14:45 UTC
Identified
Dear Customer,

Please be advised that customers will experience delayed bank settlement payments for transactions captured 14th November 2022. Authorisation for transactions in unaffected. We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 15, 2022 - 10:22 UTC
This incident affected: POS.