Delay in funding
Incident Report for Trust Payments
Resolved
Please be advised this issue has now been resolved
Posted Feb 16, 2022 - 14:56 UTC
Monitoring
Please be advised that some EURO currency settlements were not made last night due to a file transfer issue. The issue has been identified and fixed. All the outstanding payments will be made overnight.

If you are due settlements in GBP and USD these will be processed as normal today.

We apologise for any inconvenience caused. If you have any questions please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Posted Feb 16, 2022 - 13:01 UTC
Update
Please be advised that some EURO currency settlements were not made last night due to a file transfer issue. The issue has been identified and fixed. All the outstanding payments will be made overnight.

If you are due settlements in GBP and USD these will be processed as normal today.

We apologise for any inconvenience caused. If you have any questions please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Posted Feb 16, 2022 - 12:59 UTC
Identified
Please be aware that there may be a delay with funding; this is urgently being investigated and will be resolved as soon as possible. A further update will be posted here at 13:00pm GMT or sooner if resolved.
Posted Feb 16, 2022 - 10:10 UTC