Please be advised that the delayed bank settlement payments for all POS transactions for the 25th April 2023 have been resolved.
We apologise for any inconvenience caused.
If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Posted Apr 27, 2023 - 08:29 UTC
Monitoring
Please be advised that a fix to the settlement process has been deployed successfully and resubmission of the outstanding bank settlement payments has been completed this morning.
The transactions will now run through the clearing process overnight tonight avoiding any further delayed funds.
We will provide further updates in due course. We apologise for any inconvenience caused.
If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Apr 26, 2023 - 09:49 UTC
Identified
Please be advised that we have identified the source of the issue that has caused the delayed bank settlement payments today. We are treating the issue as a matter of urgency. We will provide further updates in due course. We apologise for any inconvenience caused.
If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Apr 26, 2023 - 08:08 UTC
Update
We are continuing to investigate this issue.
Posted Apr 26, 2023 - 07:35 UTC
Investigating
Please be advised that customers will experience delayed bank settlement payments for all POS transactions for the 25th April 2023.
Funds for these transactions will be delayed by at least 24 hours for Trust Payments.
We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.
If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.