POS Transactions - Settlement Payments Delayed
Incident Report for Trust Payments
Resolved
Please be advised that the issue impacting bank settlements has now been resolved. Funds have now been processed for payments.
. We apologise for any inconvenience caused.

If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted May 18, 2023 - 08:20 UTC
Update
We are continuing to investigate this issue.
Posted May 17, 2023 - 07:49 UTC
Update
Please be advised that there will be delayed bank settlement payments for POS transactions carried out between 02:00BST on 16/05 to 22:00BST on 16/05. Funds for these transactions will be delayed by 24 hours. All other transactions from 16th May will be processed and settlement payments made as normal. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted May 17, 2023 - 07:47 UTC
Investigating
Please be advised that customers may experience delayed bank settlement payments for POS transactions . We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted May 17, 2023 - 07:19 UTC
This incident affected: POS.