POS Transactions - Settlement Payments Delayed
Incident Report for Trust Payments
Resolved
Please be advised that the delayed bank settlement payments for all POS transactions captured between 02:00 GMT on 26th February to 02:00 GMT on 27th February 2023 has been resolved.

We apologise for any inconvenience caused.

If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Feb 28, 2023 - 14:26 UTC
Monitoring
Please be advised that a fix to the settlement process has been deployed successfully and resubmission of the outstanding bank settlement payments has been completed this evening.

The transactions will now run through the clearing process overnight tonight avoiding any further delayed funds.

We will provide further updates in due course once confirmation of funding processing has been successful. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Feb 27, 2023 - 21:25 UTC
Update
Please be advised that we have identified the source of the issue that has caused the delayed bank settlement payments today.

We are treating the issue as a matter of urgency in order to process the transactions through the clearing process overnight tonight avoiding any further delayed funds. A fix is now in progress and being deployed in preparation for processing the outstanding transactions this evening.

We will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Feb 27, 2023 - 16:51 UTC
Update
Please be advised that we have identified the source of the issue that has caused the delayed bank settlement payments today.

We are treating the issue as a matter of urgency in order to process the transactions through the clearing process overnight tonight avoiding any further delayed funds.

We will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Feb 27, 2023 - 11:05 UTC
Identified
Please be advised that we have identified the source of the issue that has caused the delayed bank settlement payments today.

We are treating the issue as a matter of urgency. We will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Feb 27, 2023 - 09:28 UTC
Update
Please be advised that customers bank settlement payments for all POS transactions captured between 02:00 GMT on 26th February to 02:00 GMT on 27th February 2023 have been delayed.

Funds for these transaction will be delayed by at least 24 hours for both AMEX and Trust Payments.

We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Feb 27, 2023 - 07:07 UTC
Investigating
Please be advised that customers will experience delayed bank settlement payments for all POS transactions captured between 02:00 GMT on 26th February to 02:00 GMT on 27th February 2023.

Funds for these transaction will be delayed by at least 24 hours for both AMEX and Trust Payments.

We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Feb 27, 2023 - 02:11 UTC
This incident affected: POS.