Please be advised, following a sustained period of monitoring, that the issue impacting POS transaction processing for Mastercard has now been resolved. We apologise for any inconvenience caused.
If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Jan 08, 2025 - 15:57 UTC
Monitoring
Please be advised that the issue affecting the POS Transaction processing for Mastercard has been addressed and our team is closely monitoring it to ensure complete stability and reliability. Rest assured, we'll provide further updates as we continue to validate the resolution and ensure sustained performance.
We apologise for any inconvenience caused.
If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Jan 08, 2025 - 14:45 UTC
Investigating
Please be advised that customers may continue to experience POS transaction failures for Mastercard. We are continuing to work on a fix and treating the issue as a matter of urgency. We will provide further updates in due course and apologise for any inconvenience caused.
If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Jan 08, 2025 - 13:29 UTC
Update
Please be advised that customers may continue to experience POS transaction declines for Mastercard only.
We are continuing to treat the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.
If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Jan 08, 2025 - 12:34 UTC
Identified
Please be advised that we have identified the source of the issue causing intermittent POS transaction failures for Mastercard POS transactions only.
We are continuing to treat the issue as a matter of urgency. We will provide further updates in due course. We apologise for any inconvenience caused. If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Jan 08, 2025 - 11:31 UTC
Update
Please be advised that customers may continue to experience intermittent POS transaction failures. This has been identified as affecting Mastercard POS transactions only. We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.
If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Jan 08, 2025 - 10:16 UTC
Investigating
Please be advised that customers may experience intermittent POS transaction declines. We are treating the issue as a matter of urgency. We will provide further updates in due course. We apologise for any inconvenience caused.
If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.