Bank Settlement Payments Delay
Incident Report for Trust Payments
Resolved
Please be advised that the issue impacting bank settlements has now been resolved and no delays were incurred. We apologise for any inconvenience caused.

If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 07, 2023 - 16:36 UTC
Monitoring
All bank settlement payments are processing as expected.
Technical teams will continue to monitor.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 07, 2023 - 11:35 UTC
Investigating
Please be advised that customers may experience delayed bank settlement payments. We are treating the universal issue as a matter of urgency. We will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Nov 07, 2023 - 08:33 UTC
This incident affected: Tru Acquiring.