Resolved - POS - High Decline Rates
Incident Report for Trust Payments
Resolved
Please be advised that the issue impacting POS transaction processing has now been resolved. We apologise for any inconvenience caused.

If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Posted Sep 13, 2023 - 11:51 UTC
Monitoring
Please be advised that customers may have experienced a higher number of POS transaction failures this morning between 11:16 - 11:50BST. The issue impacting POS transaction processing is returning to normal and we are continuing to monitor the situation. We can also confirm online e-commerce transactions were unaffected by this incident.

We apologise for any inconvenience caused.

If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Sep 13, 2023 - 11:09 UTC
This incident affected: POS.