AMEX POS - Transaction Declines - Resolved
Incident Report for Trust Payments
Resolved
Please be advised that the issue impacting AMEX POS transaction has been fully resolved. We apologise for any inconvenience caused.

If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Oct 09, 2024 - 17:16 UTC
Update
Please be advised that customers may continue to experience AMEX POS transaction declines. AMEX have confirmed they are treating the issue as a matter of urgency and will provide further updates in due course.

We apologise for any inconvenience caused. If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Oct 09, 2024 - 16:09 UTC
Investigating
Please be advised that customers may experience intermittent AMEX POS transaction declines. We are treating the issue as a matter of urgency. We will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Oct 09, 2024 - 12:54 UTC
This incident affected: 3DS Services (3DS API (Server-to-Server), EMV 3DS).