Please be advised that the issue impacting POS transaction processing has now been resolved. We apologise for any inconvenience caused.
If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Apr 24, 2026 - 12:54 UTC
Monitoring
Please be advised that the issue affecting the POS Transaction processing has been addressed & our team is closely monitoring it to ensure complete stability and reliability. Rest assured, we'll provide further updates as we continue to validate the resolution and ensure sustained performance.
We apologise for any inconvenience caused.
If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.
Many Thanks, The Trust Payments Team
Posted Apr 24, 2026 - 11:56 UTC
Investigating
Please be advised that at this time customers may experience POS transaction failures due to an issue with a third party. We are treating the issue as a matter of urgency. We will provide further updates in due course. We apologise for any inconvenience caused.
If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.