Modulr Payment Platform Outage

Incident Report for Trust Payments

Resolved

This incident has been resolved. We are currently monitoring to ensure it is stable. Modulr Payments and account access has been restored.
Posted May 04, 2023 - 18:19 UTC

Identified

We have identified an issue with the Modulr Payment Platform. Access to the portal and payments across Modulr are not available at this time. We are actively working to get this issue resolved.
Posted May 04, 2023 - 16:35 UTC
This incident affected: Merchant Payment Accounts.