Resolved - Reporting Delays For Tru Insight
Incident Report for Trust Payments
Resolved
Please be advised that this incident has now been resolved and expected reports have now been delivered.
Thank you for your patience and we apologise for any inconvenience this may have caused today.

If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Jul 08, 2023 - 19:09 UTC
Update
Please be advised that the issues causing reporting delays for Tru-Insight have now been fixed. Our internal process to deliver merchant reports is now working as expected. We anticipate your reports will be with you shortly after 20:00 BST.

We are treating the issue as a matter of urgency and confirmation will be provided once our processes have completed. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Jul 08, 2023 - 18:15 UTC
Update
Please be advised that the issues causing reporting delays for Tru-Insight have now been fixed. However, our internal process to deliver merchant reports is taking longer than anticipated. We are still investigating the cause of these issues and will provide an ETA as soon as possible. We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Jul 08, 2023 - 16:11 UTC
Update
Please be advised that the issues causing reporting delays for Tru-Insight has now been fixed. Internal processes are now running and expected to conclude at 17:00BST. We are treating the issue as a matter of urgency and will provide further updates in due course. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Jul 08, 2023 - 14:05 UTC
Update
Please be advised that reporting is currently still experiencing delays for Tru Insight. We are currently working to get this issue resolved as soon as possible. We are treating the issue as a matter of urgency. We apologise for any inconvenience caused.

If you have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Jul 08, 2023 - 10:59 UTC
Investigating
Please be advised that reporting will be delayed for Tru Insight. We are currently working to get this issue resolved as soon as possible. We are treating the issue as a matter of urgency. We will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Jul 08, 2023 - 08:59 UTC
This incident affected: Portal & Data Services (Tru Insight).