Mastercard - Intermittent Latency on 3DS Authentication
Incident Report for Trust Payments
Resolved
Please be advised that the issue impacting 3DS transaction processing with Mastercard has now been resolved by Mastercard and their third parties.

We apologise for any inconvenience caused.

If you continue to experience any more issues, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Jan 17, 2023 - 15:44 UTC
Monitoring
Please be advised that customers may experience intermittent 3DS transaction failures currently via Mastercard. We have detected intermittent latency processing cardholder authentication with the MasterCard Directory Server.

Visa and American Express authentication requests are unaffected.

We are engaged with Mastercard for further information and will provide further updates in due course. We apologise for any inconvenience caused.

If have any queries, please do not hesitate to contact our support team via support@trustpayments.com or +44 333 240 6000.

Many Thanks,
The Trust Payments Team
Posted Jan 17, 2023 - 15:04 UTC
This incident affected: TRU Security (3DS) (3DS API (Server-to-Server), EMV 3DS).